CONFIGURE DYNAMIC ROUTING
Configuring a complex inter-VRF solution
Page 54 | Configure VRF-lite
Configure
routing
Dynamic routing protocols are configured as required and associated with each VRF.
OSPF instance 1 is associated with VRF red. OSPF instance 2 is associated with VRF orange.
RIP and BGP use address-families as the equivalent of OSPF instances. A RIP ipv4 address-
family is created and associated with VRF blue. Appropriate IP networks are allocated to
each routing protocol instance or address-family. BGP inter-VRF routes are imported and
redistributed via each routing protocol instance or address-family. This allows each external
peer router connected in each VRF domain to be taught filtered routes to subnets in VRF
shared.
The command default-information originate ensures that OSPF or RIP within each VRF
instance redistributes, and advertises to external peers in each VRF instance, a static default
route to access the Internet via VRF shared.
BGP with ASN 100 is configured. BGP is used to provide inter-VRF communication.
BGP address-families are created. Each BGP address-family is associated with a VRF instance,
excluding VRF overlap. There is no route leakage to or from VRF overlap, so VRF overlap
does not require an associated BGP address-family to be configured.
Via the address-families, routes (prefixes) from each routing protocol associated with each
VRF instance are redistributed into BGP100. Via the VRF export maps, and ACLs they are
subsequently leaked to and from VRF shared.
Connected (interface) routes and OSPF instance 1 routes associated with VRF red are
imported and redistributed into BGP100.
awplus(config)#router ospf 1 red
awplus(config-router)#network 192.168.10.0/24 area 0
awplus(config-router)#redistribute bgp
awplus(config-router)#default-information originate
awplus(config-router)#exit
awplus(config)#router ospf 2 orange
awplus(config-router)#network 192.168.40.0/24 area 0
awplus(config-router)#redistribute static
awplus(config-router)#redistribute bgp
awplus(config-router)#default-information originate
awplus(config-router)#exit
awplus(config)#router rip
awplus(config-router)#address-family ipv4 vrf blue
awplus(config-router-af)#network 192.168.30.0/24
awplus(config-router-af)#redistribute bgp
awplus(config-router-af)#default-information originate
awplus(config-router-af)#exit-address-family
awplus(config-router)#exit