8-14
Cisco IOS Software Configuration Guide for Cisco Aironet Access Points
OL-11350-01
Chapter8 Configuring Spanning Tree Protocol
Displaying Spanning-Tree Status
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
!
interface FastEthernet0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
!
interface FastEthernet0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
bridge-group 3 path-cost 400
!
interface BVI1
ip address 1.4.64.24 255.255.0.0
no ip route-cache
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 priority 10000
bridge 2 protocol ieee
bridge 2 priority 12000
bridge 3 protocol ieee
bridge 3 priority 2900
!
line con 0
line vty 5 15
!
end
Displaying Spanning-Tree Status
To display the spanning-tree status, use one or more of the privileged EXEC commands in Table 8-3 :
For information about other keywords for the show spanning-tree privileged EXEC command, refer to
the Cisco Aironet IOS Command Reference for Cisco Aironet Access Points and Bridges for this release.
Table8-3 Commands for Displaying Spanning-Tree Status
Command Purpose
show spanning-tree Displays information on your network’s spanning tree.
show spanning-tree blocked-ports Displays a list of blocked ports on this bridge.
show spanning-tree bridge Displays status and configuration of this bridge.
show spanning-tree active Displays spanning-tree information on active interfaces only.
show spanning-tree root Displays a detailed summary of information on the spanning-tree root.
show spanning-tree interface interface-id Displays spanning-tree information for the specified interface.
show spanning-tree summary [totals] Displays a summary of port states or displays the total lines of the STP state
section.