interface TenGigabitEthernet 2/2/1
ip vrf forwarding orange
ip address 21.0.0.1/24
no shutdown
!
interface TenGigabitEthernet 2/3/1
ip vrf forwarding green
ip address 31.0.0.1/24
no shutdown
!
interface Vlan 128
ip vrf forwarding blue
ip address 1.0.0.2/24
tagged TenGigabitEthernet 3/1/1
no shutdown
interface Vlan 192
ip vrf forwarding orange
ip address 2.0.0.2/24
tagged TenGigabitEthernet 3/1/1
no shutdown
!
interface Vlan 256
ip vrf forwarding green
ip address 3.0.0.2/24
tagged TenGigabitEthernet 3/1/1
no shutdown
!
router ospf 1 vrf blue
router-id 1.0.0.2
network 11.0.0.0/24 area 0
network 1.0.0.0/24 area 0
passive-interface TenGigabitEthernet 2/1/1
!
router ospf 2 vrf orange
router-id 2.0.0.2
network 21.0.0.0/24 area 0
network 2.0.0.0/24 area 0
passive-interface TenGigabitEthernet 2/2/1
!
ip route vrf green30.0.0.0/24 3.0.0.1
!
======================================================================
=================
The following shows the output of the show commands on Router 1.
Router 1
Dell#show ip vrf
VRF-Name VRF-ID Interfaces
default-vrf 0 Te 3/1/1-3/1/4,
Te 1/3/1-1/32/4,
Te 2/1-2/32/4,
Ma 1/1,
Nu 0,
Vl 1
blue 1 Te 1/1/1,
Vl 128
orange 2 Te 1/2/1,
1020 Virtual Routing and Forwarding (VRF)