ip address 192.168.128.1/24
no shutdown
R1(conf-if-lo-0)#int te 1/21/1
R1(conf-if-te-1/21/1)#ip address 10.0.1.21/24
R1(conf-if-te-1/21/1)#no shutdown
R1(conf-if-te-1/21/1)#show config
!
interface TengigabitEthernet 1/21/1
ip address 10.0.1.21/24
no shutdown
R1(conf-if-te-1/21)#int te 1/31/1
R1(conf-if-te-1/31)#ip address 10.0.3.31/24
R1(conf-if-te-1/31)#no shutdown
R1(conf-if-te-1/31)#show config
!
interface TengigabitEthernet 1/31/1
ip address 10.0.3.31/24
no shutdown
R1(conf-if-te-1/31)#router bgp 99
R1(conf-router_bgp)#network 192.168.128.0/24
R1(conf-router_bgp)#neighbor 192.168.128.2 remote 99
R1(conf-router_bgp)#neighbor 192.168.128.2 no shut
R1(conf-router_bgp)#neighbor 192.168.128.2 update-source loop 0
R1(conf-router_bgp)#neighbor 192.168.128.3 remote 100
R1(conf-router_bgp)#neighbor 192.168.128.3 no shut
R1(conf-router_bgp)#neighbor 192.168.128.3 update-source loop 0
R1(conf-router_bgp)#show config
!
router bgp 99
network 192.168.128.0/24
neighbor 192.168.128.2 remote-as 99
neighbor 192.168.128.2 update-source Loopback 0
neighbor 192.168.128.2 no shutdown
neighbor 192.168.128.3 remote-as 100
neighbor 192.168.128.3 update-source Loopback 0
neighbor 192 168 128 3 no shutdown
Example of Enabling BGP (Router 2)
R2# conf
R2(conf)#int loop 0
R2(conf-if-lo-0)#ip address 192.168.128.2/24
R2(conf-if-lo-0)#no shutdown
R2(conf-if-lo-0)#show config
!
interface Loopback 0
ip address 192.168.128.2/24
no shutdown
R2(conf-if-lo-0)#int te 2/11/1
R2(conf-if-te-2/11/1)#ip address 10.0.1.22/24
R2(conf-if-te-2/11/1)#no shutdown
R2(conf-if-te-2/11/1)#show config
!
interface TengigabitEthernet 2/11/1
ip address 10.0.1.22/24
no shutdown
R2(conf-if-te-2/11/1)#int te 2/31/1
R2(conf-if-te-2/31/1)#ip address 10.0.2.2/24
R2(conf-if-te-2/31/1)#no shutdown
R2(conf-if-te-2/31/1)#show config
!
interface TengigabitEthernet 2/31/1
ip address 10.0.2.2/24
no shutdown
R2(conf-if-te-2/31/1)#
Border Gateway Protocol IPv4 (BGPv4) 225