Telco and ISP Dial Scenarios and Configurations

PPP Calls over X.25 Networks

Protocol Translation Configuration Example

In the following example, PAD callers that dial 4085551234 receive a router prompt. PAD callers that dial 4085555123401 start PPP and pick up an address from the IP pool called dialin_pool. These addresses are “borrowed” from the Ethernet interface on the Cisco 4500 router. Additionally, a loopback interface network can be created and the X.25 addresses can be set. However, a routing protocol must be run to advertise the loopback interface network if this method is used.

Note Be sure to include your own IP addresses, host names, and security passwords where appropriate in the following examples.

service timestamps debug datetime msec service timestamps log datetime msec service password-encryption

no service udp-small-servers no service tcp-small-servers

!

hostname NAS

!

aaa new-model

aaaauthentication login console enable aaa authentication login vty tacacs+ aaa authentication login dialin tacacs+ aaa authentication ppp default tacacs+

aaa authentication ppp dialin if-needed tacacs+ enable secret cisco

!

async-bootp dns-server 10.1.3.1 10.1.3.2

!

vty-async

vty-async ppp authentication chap pap

!

interface Loopback0

ip address 10.1.2.254 255.255.255.0

!

interface Ethernet0

ip address 10.1.1.10 255.255.255.0

ip summary address eigrp 10 10.1.2.0 255.255.255.0

!

interface Serial0 no ip address encapsulation x25

x25 address 4085551234

x25 accept-reverse

x25 default pad

!

router eigrp 10 network 10.0.0.0 passive-interface Dialer0 no auto-summary

!

ip local pool dialin_pool 10.1.2.1 10.1.2.50 ip default-gateway 10.1.1.1

!

ip classless

!

translate x25 4085555123401 ppp ip-pool scope-name dialin_pool

!

dialer-list 1 protocol ip permit

!

Cisco IOS Dial Services Configuration Guide: Network Services

DNC-332

Page 28
Image 28
Cisco Systems DNC-305 manual Protocol Translation Configuration Example, DNC-332