14 Using MLAG in Dell Networks
.
In a full mesh, all eight ports joined together in the MLAG (four blue cables) are in the same port channel
to achieve maximum redundancy.
To configure the 2-tier in a full mesh configuration, follow the steps below:
1. Enter the commands below for each corresponding switch in the topology.
2. Cable the configuration as shown.
3. Enable MLAG (using the feature vpc command) on each switch.
Similar commands are performed on all four MLAG peer switches. MLAG peers B and C are required to be
consistent in their configurations following the guidelines set in
Consistency of MLAG peers
. MLAG peers
D and E also follow the same requirements for consistency. Though MLAG partner switches A and F may
have similar configurations in this particular scenario, they have no such consistency requirements to each
other or to the peer switches.
Each column below contains commands that can be cut and pasted into a CLI session if using the same
topology as described in this example. Command sections are color-coded to allow easier comparisons
between the
BC
MLAG peers and the
DE
MLAG peers.
MLAG Peer B
MLAG Peer C
Description of commands
configure
vlan 30
exit
interface port-channel 1
description "MLAG-Peer-Link"
spanning-tree disable
switchport mode trunk
vpc peer-link
exit
interface tengigabitethernet 1/0/1
channel-group 1 mode active
description "MLAG-Peer-Link"
exit
interface port-channel 40
switchport mode trunk
switchport trunk native vlan 30
vpc 40
exit
interface port-channel 50
switchport mode trunk
switchport trunk native vlan 30
vpc 50
exit
configure
vlan 30
exit
interface port-channel 1
description "MLAG-Peer-Link"
spanning-tree disable
switchport mode trunk
vpc peer-link
exit
interface tengigabitethernet 1/0/1
channel-group 1 mode active
description "MLAG-Peer-Link"
exit
interface port-channel 40
switchport mode trunk
switchport trunk native vlan 30
vpc 40
exit
interface port-channel 50
switchport mode trunk
switchport trunk native vlan 30
vpc 50
exit
Create a VLAN for MLAG and
all partner traffic
Configure the port channel for
the BC peer link
- must be trunk mode
Identify and configure the BC
peer link interfaces
Create a LAG (port-channel)
for partner switch DE to pass
traffic
Assign a unique id for partner
switch DE
Create a LAG (port-channel)
for partner switch A to pass
traffic
Assign a unique id for partner
switch A