Configuring IP Addressing
IP Addressing Examples

IPC-61

Cisco IOS IP Configuration Guide
Figure13 IP Helper Addresses

The following example shows the configuration:

ip forward-protocol udp
!
interface ethernet 1
ip helper-address 10.44.23.7
interface ethernet 2
ip helper-address 192.168.1.19
NAT Configuration Examples

The following sections show NAT configuration examples.

Dynamic Inside Source Translation Example

The following example translates all source addresses passing access list 1 (having a source address from

192.168.1.0/24) to an address from the pool named net-208. The pool contains addresses from

171.69.233.208 to 171.69.233.223.

ip nat pool net-208 171.69.233.208 171.69.233.223 netmask 255.255.255.240
ip nat inside source list 1 pool net-208
!
interface serial 0
ip address 171.69.232.182 255.255.255.240
ip nat outside
!
interface ethernet 0
ip address 192.168.1.94 255.255.255.0
ip nat inside
!
access-list 1 permit 192.168.1.0 0.0.0.255

The following example translates all source addresses using a route map.

ip nat pool provider1-space 171.69.232.1 171.69.232.254 prefix-length 24
ip nat pool provider2-space 131.108.43.1 131.108.43.254 prefix-length 24
S1017a
Server
10.44.23.7
Server
192.168.1.19
Network 192.168.1.0
Network 10.44.0.0
E2
E1