Configuring IP Routing Protocol-Independent Features

IP Routing Protocol-Independent Configuration Examples

interface ethernet 0

ip address 192.168.110.201 255.255.255.0 ip ospf authentication-key abcdefgh

ip ospf cost 10

!

interface ethernet 1

ip address 172.19.251.201 255.255.255.0 ip ospf authentication-key ijklmnop

ip ospf cost 20

ip ospf retransmit-interval 10 ip ospf transmit-delay 2

ip ospf priority 4

!

interface ethernet 2

ip address 172.19.254.201 255.255.255.0 ip ospf authentication-key abcdefgh

ip ospf cost 10

!

interface ethernet 3

ip address 10.0.0.201 255.255.0.0 ip ospf authentication-key ijklmnop ip ospf cost 20

ip ospf dead-interval 80

In the following configuration, OSPF is on network 172.19.0.0:

router ospf 1

network 10.0.0.0 0.255.255.255 area 10.0.0.0 network 192.168.110.0 0.0.0.255 area 192.168.110.0 network 172.19.0.0 0.0.255.255 area 0

area 0 authentication area 10.0.0.0 stub

area 10.0.0.0 authentication area 10.0.0.0 default-cost 20 area 192.168.110.0 authentication

area 10.0.0.0 range 10.0.0.0 255.0.0.0

area 192.168.110.0 range 192.168.110.0 255.255.255.0 area 0 range 172.19.251.0 255.255.255.0

area 0 range 172.19.254.0 255.255.255.0

redistribute igrp 200 metric-type 2 metric 1 tag 200 subnets redistribute rip metric-type 2 metric 1 tag 200

In the following configuration IGRP autonomous system 1 is on 172.19.0.0:

router igrp 1 network 172.19.0.0

!

!RIP for 192.168.110.0

router rip

network 192.168.110.0 redistribute igrp 1 metric 1 redistribute ospf 201 metric 1

Cisco IOS IP Configuration Guide

IPC-389

Page 435
Image 435
Cisco Systems 78-11741-02 manual Following configuration, Ospf is on network, IPC-389, Area 10.0.0.0 range 10.0.0.0