Configuring BGP

BGP Configuration Examples

The following example configuration shows how to conditionally originate a default route (0.0.0.0/0) in RIP when a prefix 10.1.1.0/24 exists in the routing table:

ip prefix-list cond permit 10.1.1.0/24

!

route-map default-condition permit 10 match ip address prefix-list cond

!

router rip

default-information originate route-map default-condition

The following example shows how to configure BGP to accept routing updates from 192.1.1.1 only, besides filtering on the prefix length:

router bgp

distribute-list prefix max24 gateway allowlist in

!

ip prefix-list allowlist seq 5 permit 192.1.1.1/32

!

The following example shows how to direct the BGP process to filter incoming updates to the prefix using name1, and match the gateway (next hop) of the prefix being updated to the prefix list name2, on the Ethernet interface 0:

router bgp 103

distribute-list prefix name1 gateway name2 in ethernet 0.

Route Filtering Configuration Example Specifying a Group of Prefixes

The following example shows how to configure BGP to permit routes with a prefix length up to 24 in network 192/8:

ip prefix-list abc permit 192.0.0.0/8 le 24

The following example shows how to configure BGP to deny routes with a prefix length greater than in

25 in 192/8:

ip prefix-list abc deny 192.0.0.0/8 ge 25

The following example shows how to configure BGP to permit routes with a prefix length greater than

8 and less than 24 in all address space:

ip prefix-list abc permit 0.0.0.0/0 ge 8 le 24

The following example shows how to configure BGP to deny routes with a prefix length greater than 25 in all address space:

ip prefix-list abc deny 0.0.0.0/0 ge 25

The following example shows how to configure BGP to deny all routes in 10/8, because any route in the Class A network 10.0.0.0/8 is denied if its mask is less than or equal to 32 bits:

ip prefix-list abc deny 10.0.0.0/8 le 32

The following example shows how to configure BGP to deny routes with a mask greater than 25 in 204.70.1/24:

ip prefix-list abc deny 204.70.1.0/24 ge 25

The following example shows how to configure BGP to permit all routes:

ip prefix-list abc permit 0.0.0.0/0 le 32

Cisco IOS IP Configuration Guide

IPC-338

Page 384
Image 384
Cisco Systems 78-11741-02 manual IPC-338