Configuring IP Addressing
IP Addressing Examples

IPC-63

Cisco IOS IP Configuration Guide

TCP Load Distribution Example

In the following example, the goal is to define a virtual address, connections to which are distributed

among a set of real hosts. The pool defines the addresses of the real hosts. The access list defines the

virtual address. If a translation does not already exist, TCP packets from serial interface 0 (the outside

interface) whose destination matches the access list are translated to an address from the pool.

ip nat pool real-hosts 192.168.15.2 192.168.15.15 prefix-length 28 type rotary
ip nat inside destination list 2 pool real-hosts
!
interface serial 0
ip address 192.168.15.129 255.255.255.240
ip nat outside
!
interface ethernet 0
ip address 192.168.15.17 255.255.255.240
ip nat inside
!
access-list 2 permit 192.168.15.1
ping Command Example

You can specify the address to use as the source address for ping packets. In the following example, the

address is 131.108.105.62:

Sandbox# ping
Protocol [ip]:
Target IP address: 131.108.1.111
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: yes
Source address: 131.108.105.62
Type of service [0]:
Set DF bit in IP header? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 131.108.1.111, timeout is 2 seconds:
!!!!!
Success rate is 100 percent, round-trip min/avg/max = 4/4/4 ms