9-16
Software Configuration Guide—Release 12.2(25)EWA
OL-7659-03
Chapter9 Configuring Switches with Web-Based Tools
Configuring and Using the Network Assistant
This example shows how to configure Network Assistant on a networked switch in community m ode:
Switch# configure terminal
Switch(config)# vtp domain cnadoc
Changing VTP domain name from cisco to cnadoc
Switch(config)# vlan 2
Switch(config-vlan)# interface GigabitEthernet 2/1
Switch(config-if)# switchport access vlan 2
Switch(config-if)# interface vlan 2
Switch(config-if)# ip address 123.123.123.1 255.255.255.0
Switch(config-if)# no shut
Switch(config-if)# ip http server
Switch(config-if)# ip http secure-server
Switch(config)# ip route 0.0.0.0 0.0.0.0 123.123.123.2
Switch(config)# line con 0
Switch(config-line)# exec-timeout 0 0
Switch(config-line)# password keepout
Switch(config-line)# login
Switch(config-line)# line vty 5 15
Switch(config-line)# password keepout
Switch(config-line)# login
Switch(config-line)# line vty 5 15
Switch(config-line)# end
Switch# show running-config
Building configuration...
Current configuration : 1426 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
enable password cna
!
no aaa new-model
ip subnet-zero
!
vtp domain cnadoc
Step16 Switch(config-line)# login Allows login to the console port.
Step17 Switch(config-line)# line vty
x y
Creates additional VTY lines for CNA to access the switch.
Step18 Switch(config-line)# password
password
Specifies a password for the switch.
Step19 Switch(config-line)# login Allows login to the switch.
Step20 Switch(config-line)# line vty
x y
Creates additional VTY lines for CNA to access the switch.
Step21 Switch(config-line)# password
password
Specifies a password for the switch.
Step22 Switch(config-line)# login Allows login to the switch.
Step23 Switch(config-line)# end Returns to privileged EXEC mode.
Step24 Switch# show running-config Verifies the configuration.
Command Purpose