9-19
Software Configuration Guide—Release 12.2(25)EWA
OL-7659-03
Chapter9 Configuring Switches wi th Web-Based Tools
Configuring and Using the Network Assistant
This example shows how to configure Network Assistant on a networked switch in cluster mode:
Switch# configure terminal
Switch(config)# vtp domain cnadoc
Switch(config)# cluster run
Switch(config)# cluster enable cnadoc
Switch(config)# vlan 10
Switch(config-vlan)# interface GigabitEthernet 2/1
Switch(config-if)# switchport access vlan 10
Switch(config-if)# interface vlan10
Switch(config-if)# ip address aa.bb.cc.dd
Switch(config-if)# no shut
Switch(config-if)# ip http server
Switch(config-if)# ip http secure-server
Switch(config)# ip route 0.0.0.0 0.0.0.0 123.123.123.2
Switch(config)# line con 0
Switch(config-line)# exec-timeout 0 0
Switch(config-line)# password keepout
Switch(config-line)# login
Switch(config-line)# line vty 5 15
Switch(config-line)# password keepout
Switch(config-line)# login
Switch(config-line)# line vty 5 15
Switch(config-line)# end
Switch# show running-config
Building configuration...
Current configuration : 1469 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
Step16 Switch(config-line)# exec-timeout
x y
Configures an automatic session logout if no keyboard input or output is displayed on the terminal.
Step17 Switch(config-line)# password
password
Specifies a password for the console port.
Step18 Switch(config-line)# login Allows login to the console port.
Step19 Switch(config-line)# line vty
x y
Creates additional VTY lines for CNA to access the switch.
Step20 Switch(config-line)# password
password
Specifies a password for the switch.
Step21 Switch(config-line)# login Allows login to the switch.
Step22 Switch(config-line)# line vty
x y
Creates additional VTY lines for CNA to access the switch.
Step23 Switch(config-line)# password
password
Specifies a password for the switch.
Step24 Switch(config-line)# login Allows login to the switch.
Step25 Switch(config-line)# end Returns to privileged EXEC mode.
Step26 Switch# show running-config| include http Verifies that the HTTP server is enabled.
Command Purpose