16-10
Software Configuration Guide—Release 12.2(25)SG
OL-7659-03
Chapter16 Understanding and Configuring EtherChannel
Configuring EtherChannel
To configure Layer2 Ethernet interfaces as Layer 2 EtherChannels, perform this task for each interface:
This example shows how to configure Fast Ethernet interfaces 5/6 and 5/7 into port-chann el 2 with PAgP
mode desirable:
Switch# configure terminal
Switch(config)# interface range fastethernet 5/6 - 7 (Note: Space is mandatory.)
Switch(config-if-range)# channel-group 2 mode desirable
Switch(config-if-range)# end
Note See the “Configuring a Range of Interfaces” section on page 4-4 for information about the range
keyword.
This example shows how to verify the configuration of port-channel interface 2:
Switch# show running-config interface port-channel 2
Building configuration...
Current configuration:
!
interface Port-channel2
switchport access vlan 10
switchport mode access
end
Switch#
The following two examples show how to verify the configuration of Fast Ethernet interface 5/6:
Switch# show running-config interface fastethernet 5/6
Building configuration...
Current configuration:
!
interface FastEthernet5/6
switchport access vlan 10
switchport mode access
channel-group 2 mode desirable
end
Command Purpose
Step1 Switch(config)# interface {fastethernet | gigabitethernet
| tengigabitethernet}
slot
/
port
Selects a physical interface to configure.
Step2 Switch(config-if)# channel-group
port_channel_number
mode
{active | on | auto | passive | desirable}
Configures the interface in a port-channel and
specify the PAgP or LACP mode.
If you use PAgP, select the keywords active
and desirable.
If you use LACP, select the keywords active
and passive.
Step3 Switch(config-if)# end Exits configuration mode.
Step4 Switch# show running-config interface {fastethernet |
gigabitethernet}
slot
/
port
Switch# show interface {fastethernet | gigabitethernet |
tengigabitethernet}
slot
/
port
etherchannel
Verifies the configuration.