User Manual - Configuration Guide (Volume 3)
Versatile Routing Platform Chapter 3
Configuration of GRE
3-8
RouterA(config-if-Ethernet0)# ip address 10.1.1.1 255.255.255.0
RouterA(config-if-Ethernet0)# ipx network 1e
! Enter tunnel source interface.
RouterA(config)# interface serial 0
RouterA(config-if-Serial0)# ip address 192.13.2.1 255.255.255.0
! Create virtual tunnel interface and configure tunnel interface
RouterA(config)# interface tunnel 0
RouterA(config-if-tunnel0)# ip address 10.1.2.1 255.255.255.0
RouterA(config-if-tunnel0)# ipx network 1f
! Designate that tunnel working mode is GRE and transmission protocol is I P.
RouterA(config-if-tunnel0)# tunnel mode gre ip
! Configure the source address of tunnel interface (It should be IP address of Seri al0 of
RouterA).
RouterA(config-if-tunnel0)# tunnel source 192.13.2.1
! Configure the opposite end IP address of tunnel interface (It should be I P address of
Serial0 of RouterB).
RouterA(config-if-tunnel0)# tunnel destination 131.108.5.2
! Configure a static route to Group2.
RouterA(config)# ipx route 31 1f.a.a.a 30000 15
The configurations of Router B are as follows:
! Activate IPX.
RouterB(config)# ipx routing b.b.b
! Configure interface “Ethernet0”.
RouterB(config)# interface ethernet 0
RouterB(config-if-Ethernet0)# ip address 10.1.3.1 255.255.255.0
RouterB(config-if-Ethernet0)# ipx network 31
! Enter tunnel source interface.
RouterB(config)# interface serial 0
RouterB(config-if-Serial0)# ip address 131.108.5.2 255.255.255.0
! Create and enter “Tunnel0” interface configuration mode.
RouterB(config)# interface tunnel 0
RouterB(config-if-tunnel0)# ip address 10.1.2.2 255.255.255.0
RouterB(config-if-tunnel0)# ipx network 1f
! Designate that tunnel working mode is GRE and transmission protocol is I P.
RouterB(config-if-tunnel0)# tunnel mode gre ip
! Configure the source address of Tunnel0 interface (It should be IP addres s of Serial0
of RouterB).
RouterB(config-if-tunnel0)# tunnel source 131.108.5.2
! Explain the opposite end address of Tunnel0 interface (It should be IP a ddress of
Serial0 of RouterA).