QoS Policy Configuration Examples

XSR(config)#interface multilink 1

XSR(config-if<M1>)#service-policy input InOut

XSR(config-if<M1>)#exit

XSR(config)#interface fastethernet 1

XSR(config-if<F1>)#service-policy output InOut

Input QoS on Ingress to the Diffserv Domain Policy

If the XSR is positioned on the edge of the diffserv (DS) domain, it must perform edge traffic conditioning required by the diffserv domain for traffic entering from outside the domain. Traffic conditioning on input QoS include marking and policing.

In the following example, the Ethernet interface is situated outside the DS domain. All other XSR interfaces belong to the DS domain. Incoming traffic is classified in three flows: RTP traffic which is marked with the EF code point, traffic flow for destination 10.10.10.0 which is policed to 10 Mbps, and FTP traffic which is policed to 5Mbps with conforming traffic marked with AF=21 and exceeding traffic marked with AF=23. All other traffic is marked with DSCP=0 and policed to 10 Mbps.

XSR(config)#class-map RTP

XSR(config-cmap<RTP>)#match access-group 110

XSR(config-cmap<RTP>)#exit

XSR(config)#class-map Dest10

XSR(config-cmap<Dest10>)#match access-group 112

XSR(config-cmap<Dest10>)#exit

XSR(config)#class-map FTP

XSR(config-cmap<RTP>)#match access-group 113

XSR(config-cmap<RTP>)#exit

XSR(config)#access-list 110 permit udp any any eq 3020

XSR(config)#access-list 112 permit tcp any 10.10.10.0 0.0.0.255

XSR(config)#access-list 113 permit tcp any any range 20 21

XSR(config)#policy-map Eht XSR(config-pmap<Eht>)#class RTP XSR(config-pmap-c<RTP>)#set ip dscp EF XSR(config-pmap-c<RTP>)#exit XSR(config-pmap<Eht>)#class Dest10 XSR(config-pmap-c<Dest10>)#police 10000000 10000 XSR(config-pmap-c<Dest10>)#exit XSR(config-pmap<Eht>)#class FTP

XSR(config-pmap-c<FTP>)#police 5000000 10000 conform-action set-dscp-transmit 21 exceed-action set-dscp-transmit 23

XSR(config-pmap-c<FTP>)#exit XSR(config-pmap<Eht>)#class class-default XSR(config-pmap-c<class-default>)#set ip dscp 0 XSR(config-pmap-c<class-default>)#police 10000000 10000 XSR(config-pmap-c<class-default>)#exit XSR(config-pmap<Eht>)#exit

XSR User’s Guide 12-29

Page 311
Image 311
Enterasys Networks X-PeditionTM manual Input QoS on Ingress to the Diffserv Domain Policy