37-42
Software Configuration Guide—Release 15.0(2)SG
OL-23818-01
Chapter 37 Configuring Quality of Service
Configuring QoS on Supervisor Engines II-Plus, II+10GE, IV, V, V-10GE, 4924, 4948, and 4948-10GE
Note In a hierarchal policer configuration with parent as aggregate policer and child as microflow policer,
child microflow policer matched packets report only the packets that are in the profile (that is, match the
policing rate). Packets that exceed the policing rate are not reported in the class-map packet match
statistics.
This example shows how to create a hierarchical policy map. A policy map with the name
aggregate-policy has a class map with the name aggregate-class. A flow-based policy map with the name
flow-policy is attached to this policy map as a child policy map.
Switch# config terminal
Switch(config)# policy-map aggregate-policy
Switch(config-pmap)# class aggregate-class
Switch(config-pmap-c)# service-policy flow-policy
Switch(config-pmap-c)# end
Switch#
In the following example, traffic in the IP address range of 101.237.0.0 to 101.237.255.255 is policed to
50 MBps. Flows ranging from 101.237.10.0 to 101.237.10.255 are individually policed to a rate of two
MBps. This traffic goes through two policers: the aggregate policer and the other flow-based policer.
The following example shows the configuration for this scenario:
class-map match-all flow-class
match flow ip source-address
match access-group 20
!
class-map match-all aggregate-class
match access-group 10
!
policy-map flow-policy
class flow-class
police 2000000 bps 10000 byte conform-action transmit exceed-action drop
!
policy-map aggregate-policy
class aggregate-class
police 50000000 bps 40000 byte conform-action transmit exceed-action drop
service-policy flow-policy
!
access-list 10 permit 101.237.0.0 0.0.255.255
access-list 20 permit 0.0.10.0 255.255.0.255
The following example shows how to verify the configuration:
Switch# show policy-map flow-policy
Policy Map flow-policy
Class flow-class
police 2000000 bps 10000 byte conform-action transmit exceed-action drop
Switch# show policy-map aggregate-policy
Policy Map aggregate-policy
Class aggregate-class
police 50000000 bps 40000 byte conform-action transmit exceed-action drop
service-policy flow-policy
Switch# show policy-map interface
FastEthernet6/1
Service-policy input: aggregate-policy
Class-map: aggregate-class (match-all)
132537 packets
Match: access-group 10
police: Per-interface