2-5
Cisco ASA 5500 Series Configuration Guide using ASDM
Chapter2 Getting Started
Configuring ASDM Access for Appliances
Examples
The following configuration converts the firewall mode to transparent mode, configures the VLAN 1
interface and assigns it to BVI 1, enables a switchport, and enables ASDM for a management host:
firewall transparent
interface bvi 1
ip address 192.168.1.1 255.255.255.0
interface vlan 1
bridge-group 1
nameif inside
security-level 100
interface ethernet 0/1
switchport access vlan 1
no shutdown
dhcpd address 192.168.1.5-192.168.1.254 inside
dhcpd enable inside
http server enable
http 192.168.1.0 255.255.255.0 inside
Accessing ASDM Using a Non-Default Configuration (ASA 5510 and Higher)
If you do not have a factory default configuration, or want to change the firewall or context mode,
perform the following steps.
Prerequisites
Access the CLI according to the “Accessing the Appliance Command-Line Interface” section on
page 2-1.
Detailed Steps
Command Purpose
Step1 (Optional)
firewall transparent
Example:
hostname(config)# firewall transparent
Enables transparent firewall mode. This command clears your
configuration. See the “Configuring the Firewall Mode” section
on page 10-1 for more information.
Step2 interface management 0/0
ip address ip_address mask
nameif name
security-level number
no shutdown
Example:
hostname(config)# interface management 0/0
hostname(config-if)# ip address
192.168.1.1 255.255.255.0
hostname(config-if)# nameif management
hostname(config-if)# security-level 100
hostname(config-if)# no shutdown
Configures the Management 0/0 interface. The security-level is a
number between 1 and 100, where 100 is the most secure.