Chapter 1: General Information

Network Time Protocol Synchronization Specifications

1.11Network Time Protocol Synchronization Specifications

TimeVault’s hardware is specifically designed to implement the NTP server function. As such, it was carefully designed to minimize the unknown latencies in timestamping received and transmitted NTP packets. The NTP timestamp accuracy specifications are:

Received Timestamp Accuracy: <0.1 ms, relative to synchronization source

Transmitted Timestamp Accuracy: <0.1 ms, relative to synchronization source

At these levels, the realizable NTP synchronization accuracy of any host is determined by the repeatability of network and client delays, not by TimeVault’s timestamp uncertainty.

TimeVault supports the following protocols:

 

•

Telnet

RFC-854

•

DAYTIME (available in TCP and UDP protocols)

RFC-867

•

TIME (available in TCP and UDP protocols)

RFC-868

•

FTP

RFC-959

•

SMI

RFC-1155

•

SNMP

RFC-1157

•

MIB

RFC-1212

•

MIB II

RFC-1213

•

NTP ver. 4.0

N/A

 

(backwards compatible with NTP ver.2, RFC-1119, and ver.3, RFC-1305**)

•

MD5

RFC-1321

•

SNTP

RFC-2030

•

HTTP

RFC-2068 and 2616

•

DHCP

RFC-2132

*SMI = Structure of Management Information

**TimeVault does not implement the “authenticator field” of the NTP packet as described in Appendix C of RFC-1305.

Complete RFC information is available at http://www.ietf.org/

An NTP or SNTP client, compatible with the computer platform you use and configured to use TimeVault’s NET Port IP address, is required for accurate network synchronization. In this manual, refer to Appendix A and Appendix B for details about NTP and SNTP protocols, and Appendix D for details about SNMP and MIB.

Note: A number of NTP-related programs, such as NTPDC and NTPQ, are not supported, in the conventional sense, by Dr. Mills’ NTP, and therefore cannot be supported by Symmetricom, Inc. (TrueTime, Inc. is now Symmetricom, Inc.). The user of these programs does so at his or her own risk.

1-6

TimeVault™ User’s Manual

6000-100Ch1.fm Rev. D

Page 20
Image 20
Symmetricom Time Server user manual Network Time Protocol Synchronization Specifications