2-4
Cisco ASA 5500 Series Configuration Guide using the CLI
Chapter2 Getting Started
Configuring ASDM Access for Appliances
Transparent mode:
interface bvi number
ip address ip_address [mask]
interface vlan number
bridge-group bvi_number
nameif name
security-level level
Example:
hostname(config)# interface bvi 1
hostname(config-if)# ip address
192.168.1.1 255.255.255.0
hostname(config)# interface vlan 1
hostname(config-if)# bridge-group 1
hostname(config-if)# nameif inside
hostname(config-if)# security-level 100
Configures a bridge virtual interface and assigns a management
VLAN to the bridge group. The security-level is a number
between 1 and 100, where 100 is the most secure.
Step3 interface ethernet 0/n
switchport access vlan number
no shutdown
Example:
hostname(config)# interface ethernet 0/1
hostname(config-if)# switchport access
vlan 1
hostname(config-if)# no shutdown
Enables the management switchport and assigns it to the
management VLAN.
Step4 dhcpd address ip_address-ip_address
interface_name
dhcpd enable interface_name
Example:
hostname(config)# dhcpd address
192.168.1.5-192.168.1.254 inside
hostname(config)# dhcpd enable inside
Enables DHCP for the management host on the management
interface network. Make sure you do not include the management
address in the range.
Note By default, the IPS module, if installed, uses 192.168.1.2
for its internal management address, so be sure not to use
this address in the DHCP range. You can later change the
IPS module management address using the ASA if
required.
Step5 http server enable
Example:
hostname(config)# http server enable
Enables the HTTP server for ASDM.
Step6 http ip_address mask interface_name
Example:
hostname(config)# http 192.168.1.0
255.255.255.0 inside
Allows the management host to access ASDM.
Step7 write memory
Example:
hostname(config)# write memory
Saves the configuration.
Step8 To launch ASDM, see the “Starting ASDM”
section on page2-6.
Launches ASDM.
Command Purpose