Chapter 9 Configuring Security Features
Configuring VPN
crypto map dynmap isakmp authorization list
!
!Defines the key association and authentication for IPsec tunnel. crypto isakmp policy 1
hash md5
authentication
crypto isakmp key cisco123 address 200.1.1.1
!Defines encryption and transform set for the IPsec tunnel. crypto ipsec
!Associates all crypto values and peering address for the IPsec tunnel. crypto map to_corporate 1
set peer 200.1.1.1
set
!VLAN 1 is the internal home network.
interface vlan 1
ip address 10.1.1.1 255.255.255.0 ip nat inside
ip inspect firewall in ! Inspection examines outbound traffic. crypto map
no cdp enable
!
!FE4 is the outside or
ip address 210.110.101.21 255.255.255.0
!acl 103 permits IPsec traffic from the corp. router as well as
!denies
ip
no cdp enable
crypto map to_corporate ! Applies the IPsec tunnel to the outside interface.
!
!Utilize NAT overload in order to make best use of the
!single address provided by the ISP.
ip nat inside source list 102 interface Ethernet1 overload ip classless
ip route 0.0.0.0 0.0.0.0 210.110.101.1 no ip http server
!
!
!acl 102 associated addresses used for NAT.
!acl 103 defines traffic allowed from the peer for the IPsec tunnel.
!Allow ICMP for debugging but should be disabled because of security implications.
!acl 105 matches addresses for the IPsec tunnel to or from the corporate network.
no cdp run
| Cisco 819 Series Integrated Services Routers Software Configuration Guide |
|