Chapter 38 Configuring IP Unicast Routing

Configuring Multi-VRF CE

Switch(config)# interface vlan118

Switch(config-if)#ip vrf forwarding v12

Switch(config-if)#ip address 118.0.0.8 255.255.255.0

Switch(config-if)# exit

Switch(config)# interface vlan208

Switch(config-if)#ip vrf forwarding v11

Switch(config-if)#ip address 208.0.0.8 255.255.255.0

Switch(config-if)# exit

Configure OSPF routing in VPN1 and VPN2.

Switch(config)# router ospf 1 vrf vl1

Switch(config-router)#redistribute bgp 800 subnets

Switch(config-router)#network 208.0.0.0 0.0.0.255 area 0

Switch(config-router)# exit

Switch(config)# router ospf 2 vrf vl2

Switch(config-router)#redistribute bgp 800 subnets

Switch(config-router)#network 118.0.0.0 0.0.0.255 area 0

Switch(config-router)# exit

Configure BGP for CE to PE routing.

Switch(config)# router bgp 800

Switch(config-router)#address-family ipv4 vrf vl2

Switch(config-router-af)#redistribute ospf 2 match internal

Switch(config-router-af)#neighbor 83.0.0.3 remote-as 100

Switch(config-router-af)# neighbor 83.0.0.3 activate

Switch(config-router-af)#network 8.8.2.0 mask 255.255.255.0

Switch(config-router-af)# exit

Switch(config-router)#address-family ipv4 vrf vl1

Switch(config-router-af)#redistribute ospf 1 match internal

Switch(config-router-af)#neighbor 38.0.0.3 remote-as 100

Switch(config-router-af)# neighbor 38.0.0.3 activate

Switch(config-router-af)#network 8.8.1.0 mask 255.255.255.0

Switch(config-router-af)# end

Configuring Switch D

Switch D belongs to VPN 1. Configure the connection to Switch A by using these commands.

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)# ip routing

Switch(config)# interface gigabitethernet1/0/2

Switch(config-if)# no switchport

Switch(config-if)#ip address 208.0.0.20 255.255.255.0

Switch(config-if)# exit

Switch(config)# router ospf 101

Switch(config-router)#network 208.0.0.0 0.0.0.255 area 0

Switch(config-router)# end

 

 

Catalyst 3750-E and 3560-E Switch Software Configuration Guide

 

 

 

 

 

 

OL-9775-02

 

 

38-73

 

 

 

 

 

Page 933
Image 933
Cisco Systems 3750E manual 38-73, Switchconfig-router-af#network 8.8.2.0 mask, Switchconfig-router-af#network 8.8.1.0 mask