Chapter 38 Configuring IP Unicast Routing

Configuring BGP

Router B:

Switch(config)# router bgp 200

Switch(config-router)#neighbor 129.213.1.2 remote-as 100

Switch(config-router)#neighbor 175.220.1.2 remote-as 200

Router C:

Switch(config)# router bgp 200

Switch(config-router)#neighbor 175.220.212.1 remote-as 200

Switch(config-router)#neighbor 192.208.10.1 remote-as 300

Router D:

Switch(config)# router bgp 300

Switch(config-router)#neighbor 192.208.10.2 remote-as 200

To verify that BGP peers are running, use the show ip bgp neighbors privileged EXEC command. This is the output of this command on Router A:

Switch# show ip bgp neighbors

BGP neighbor is 129.213.1.1, remote AS 200, external link

BGP version 4, remote router ID 175.220.212.1

BGP state = established, table version = 3, up for 0:10:59

Last read 0:00:29, hold time is 180, keepalive interval is 60 seconds

Minimum time between advertisement runs is 30 seconds

Received 2828 messages, 0 notifications, 0 in queue

Sent 2826 messages, 0 notifications, 0 in queue

Connections established 11; dropped 10

Anything other than state = established means that the peers are not running. The remote router ID is the highest IP address on that router (or the highest loopback interface). Each time the table is updated with new information, the table version number increments. A table version number that continually increments means that a route is flapping, causing continual routing updates.

For exterior protocols, a reference to an IP network from the network router configuration command controls only which networks are advertised. This is in contrast to Interior Gateway Protocols (IGPs), such as EIGRP, which also use the network command to specify where to send updates.

For detailed descriptions of BGP configuration, see the “IP Routing Protocols” part of the Cisco IOS IP Configuration Guide, Release 12.2. For details about specific commands, see the Cisco IOS IP Command Reference, Volume 2 of 3: Routing Protocols, Release 12.2. See Appendix C, “Unsupported Commands in Cisco IOS Release 12.2(37)SE,” for a list of BGP commands that are visible but not supported by the switch.

Managing Routing Policy Changes

Routing policies for a peer include all the configurations that might affect inbound or outbound routing table updates. When you have defined two routers as BGP neighbors, they form a BGP connection and exchange routing information. If you later change a BGP filter, weight, distance, version, or timer, or make a similar configuration change, you must reset the BGP sessions so that the configuration changes take effect.

There are two types of reset, hard reset and soft reset. Cisco IOS Releases 12.1 and later support a soft reset without any prior configuration. To use a soft reset without preconfiguration, both BGP peers must support the soft route refresh capability, which is advertised in the OPEN message sent when the peers

 

Catalyst 3750-E and 3560-E Switch Software Configuration Guide

38-50

OL-9775-02

Page 910
Image 910
Cisco Systems 3750E manual Managing Routing Policy Changes, 38-50, Switchconfig-router#neighbor 192.208.10.2 remote-as