Chapter 38 Configuring IP Unicast Routing

Configuring Multi-VRF CE

Configuring Switch A

On Switch A, enable routing and configure VRF.

Switch# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)# ip routing

Switch(config)# ip vrf v11

Switch(config-vrf)# rd 800:1

Switch(config-vrf)#route-target export 800:1

Switch(config-vrf)#route-target import 800:1

Switch(config-vrf)# exit

Switch(config)# ip vrf v12

Switch(config-vrf)# rd 800:2

Switch(config-vrf)#route-target export 800:2

Switch(config-vrf)#route-target import 800:2

Switch(config-vrf)# exit

Configure the loopback and physical interfaces on Switch A. Gigabit Ethernet port 1 is a trunk connection to the PE. Gigabit Ethernet ports 8 and 11 connect to VPNs:

Switch(config)# interface loopback1

Switch(config-if)#ip vrf forwarding v11

Switch(config-if)#ip address 8.8.1.8 255.255.255.0

Switch(config-if)# exit

Switch(config)# interface loopback2

Switch(config-if)#ip vrf forwarding v12

Switch(config-if)#ip address 8.8.2.8 255.255.255.0

Switch(config-if)# exit

Switch(config)# interface gigabitethernet1/0/5

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode trunk

Switch(config-if)# no ip address

Switch(config-if)# exit

Switch(config)# interface gigabitethernet1/0/8

Switch(config-if)#switchport access vlan 208

Switch(config-if)# no ip address

Switch(config-if)# exit

Switch(config)# interface gigabitethernet1/0/11

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode trunk

Switch(config-if)# no ip address

Switch(config-if)# exit

Configure the VLANs used on Switch A. VLAN 10 is used by VRF 11 between the CE and the PE. VLAN 20 is used by VRF 12 between the CE and the PE. VLANs 118 and 208 are used for the VPNs that include Switch F and Switch D, respectively:

Switch(config)# interface vlan10

Switch(config-if)#ip vrf forwarding v11

Switch(config-if)#ip address 38.0.0.8 255.255.255.0

Switch(config-if)# exit

Switch(config)# interface vlan20

Switch(config-if)#ip vrf forwarding v12

Switch(config-if)#ip address 83.0.0.8 255.255.255.0

Switch(config-if)# exit

 

Catalyst 3750-E and 3560-E Switch Software Configuration Guide

38-72

OL-9775-02

Page 932
Image 932
Cisco Systems 3750E manual Configuring Switch a, 38-72