Typical X.25 Configuration Example 235
Note that you must configure a virtual IP address and two static routes on
interface Serial 1 to deceive the router because two lines connected to the same
peer exist in router RouterC. Thus load balancing can be achieved because router
RouterC will deem that there are two routes connected to network segment
10.1.1.0.
1Configure RouterA
aConfigure interface Ethernet 0.
[Router]interface ethernet 0
[Router-Ethernet0]ip address 10.1.1.1 255.255.255.0
bConfigure interface Serial 0.
[Router]interface serial 0
[Router-Serial0]link-protocol x25 dte
[Router-Serial0]x25 x121-address 1111
[Router-Serial0]ip address 1.1.1.1 255.255.255.0
[Router-Serial0]x25 map ip 1.1.1.3 x121-address 3333
[Router-Serial0]x25 vc-per-map 2
cConfigure static route to RouterC.
[Router]ip route-static 10.3.1.0 24 1.1.1.3
2Configure RouterB
aConfigure interface Ethernet 0.
[Router]interface ethernet 0
[Router-Ethernet0]ip address 10.2.1.1 255.255.255.0
bConfigure interface Serial 0.
[Router]interface serial 0
[Router-Serial0]link-protocol x25 dte
[Router-Serial0]x25 x121-address 2222
[Router-Serial0]ip address 1.1.1.2 255.255.255.0
[Router-Serial0]x25 map ip 1.1.1.3 x121-address 3333
[Router-Serial0]x25 vc-per-map 2
cConfigure static route to RouterC.
[Router]ip route-static 10.3.1.0 24 1.1.1.3
Configure router RouterC
dConfigure interface Ethernet 0.
[Router]interface ethernet 0
[Router-Ethernet0]ip address 10.3.1.1 255.255.255.0
eConfigure interface Serial 0.
[Router]interface serial 0
[Router-Serial0]link-protocol x25 dte
[Router-Serial0]x25 x121-address 3333
[Router-Serial0]ip address 1.1.1.3 255.255.255.0
[Router-Serial0]x25 map ip 1.1.1.1 x121-address 1111
[Router-Serial0]x25 map ip 2.1.1.1 x121-address 1111
[Router-Serial0]x25 map ip 1.1.1.2 x121-address 2222
[Router-Serial0]x25 map ip 2.1.1.2 x121-address 2222
fConfigure interface Serial 1.
[Router]interface serial 1
[Router-Serial1]link-protocol x25 dte