9-11

Cisco ONS 15530 Configuration Guide and Command Reference
78-14227-01, Cisco IOS Release 12.1(10)EV2
Chapter9 Monitoring Your Netw ork Topology
Configuring IP on the OSC
Node2# configure terminal
Node2(config)# interface loopback 1
Node2(config-if)# ip address 10.1.2.2 255.255.255.0
Node2(config-if)# exit
Node2(config)# interface wave 3/0
Node2(config-if)# ip unnumbered loopback 1
Node2(config-if)# exit
Node2(config)# interface wave 3/1
Node2(config-if)# ip unnumbered loopback 1
Node2(config)# router ospf 1
Node2(config-router)# network 10.1.0.0 0.0.255.255 area 0
Node3# configure terminal
Node3(config)# interface loopback 1
Node3(config-if)# ip address 10.1.3.3 255.255.255.0
Node3(config-if)# exit
Node3(config)# interface wave 2/0
Node3(config-if)# ip unnumbered loopback 1
Node3(config-if)# exit
Node3(config)# interface wave 2/1
Node3(config-if)# ip unnumbered loopback 1
Node3(config)# router ospf 1
Node3(config-router)# network 10.1.0.0 0.0.255.255 area 0
Displaying the OSC Configuration

To display the OSC configuration, use the following EXEC command:

Example

The following example shows the OSC configuration:

Switch# show interfaces wave 2/0
Wave2/0 is up, line protocol is up
Channel: 0 Frequency: 191.9 Thz Wavelength: 1562.23 nm
Laser safety control: Off
Osc physical port: Yes
Wavelength used for inband management: No
Configured threshold Group: None
Last clearing of "show interface" counters never
Hardware is OSC_phy_port
Internet address is 1.0.0.3/16
MTU 1492 bytes, BW 10000000 Kbit, DLY 0 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation SNAP, loopback not set
Last input 00:00:01, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
13929 packets output, 919730 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
Command Purpose

show interfaces wave slot/subcard Displays the OSC wave interface configuration.