9-10
Cisco ONS 15530 Configuration Guide and Command Reference
78-14227-01, Cisco IOS Release 12.1(10)EV2
Chapter9 Monitoring Your Network Topology
Configuring IP on the OSC
Note For detailed information about configuring routing protocols, refer to the Cisco IOS IP and IP
Routing Configuration Guide.
Example
The following example shows how to configure IP on the OSC on a three-node system. Node 1 connects
to the NMS (network management system).
Node1# configure terminal
Node1(config)# interface loopback 1
Node1(config-if)# ip address 10.1.1.1 255.255.255.0
Node1(config-if)# exit
Node1(config)# interface fastethernet 0
Node1(config-if)# ip address 20.1.1.1 255.255.255.0
Node1(config-if)# exit
Node1(config)# interface wave 4/0
Node1(config-if)# ip unnumbered loopback 1
Node1(config-if)# exit
Node1(config)# interface wave 4/1
Node1(config-if)# ip unnumbered loopback 1
Node1(config)# router ospf 1
Node1(config-router)# network 10.1.0.0 0.0.255.255 area 0
Node1(config-router)# network 20.1.0.0 0.0.255.255 area 0
Step10 Switch(config)# interface wave slot/1
Switch(config-if)#
Selects the wave interface in subcard 1.
Step11 Switch(config-if)# ip unnumbered loopback1 Configures an unnumbered interface referencing
the loopback interface.
Step12 Switch(config-if)# exit
Switch(config)#
Exits interface configuration mode and returns to
global configuration mode.
Step13 Switch(config)# ip route prefix prefix-mask
interface
or
Switch(config)# router ospf process-id
Switch(config-router)# network
network-address wildcard-mask area area-id
or
Switch(config)# router eigrp as-number
Switch(config-router)# network
network-number [network-mask]
or
Switch(config)# router bgp as-number
Switch(config-router)# network
network-number [mask network-mask]
Switch(config-router)# neighbor {ip-address |
peer-group-name} remote-as number
Configures IP static routes for some or all
destinations.
or
Configures OSPF as the routing protocol.
or
Configures EIGRP as the routing protocol.
or
Configures BGP as the routing protocol.
Command Purpose