122 CHAPTER 15: ROUTING CONFIGURATION GUIDE
vlan 300
#
interface Vlan-interface200
ip address 30.1.1.2 255.255.255.0
#
interface Vlan-interface300
ip address 30.1.2.1 255.255.255.0
#
ospf 1 router-id 4.4.4.4
import-route static
area 0.0.0.2
network 30.1.1.0 0.0.0.255
network 30.1.2.0 0.0.0.255
#
ip route-static 1.1.3.0 255.255.255.0 30.1.2.2 preference 60
ip route-static 1.1.4.0 255.255.255.0 30.1.2.2 preference 60
ip route-static 1.1.5.0 255.255.255.0 30.1.2.2 preference 60
ip route-static 1.1.6.0 255.255.255.0 30.1.2.2 preference 60
ip route-static 1.1.7.0 255.255.255.0 30.1.2.2 preference 60
#

ASBR route summarization configuration 1

nConfigure ASBR route summarization on Switch D.
Configure Switch A.
#
vlan 100
#
vlan 200
#
interface Vlan-interface100
ip address 10.1.1.1 255.255.255.0
#
interface Vlan-interface200
ip address 20.1.1.1 255.255.255.0
#
ospf 1 router-id 1.1.1.1
area 0.0.0.1
network 20.1.1.0 0.0.0.255
nssa
#
area 0.0.0.0
network 10.1.1.0 0.0.0.255
#
Configure Switch B.
#
vlan 100
#
vlan 200
#
interface Vlan-interface100
ip address 10.1.1.2 255.255.255.0
#
interface Vlan-interface200
ip address 30.1.1.1 255.255.255.0
#