362 Configuring Switch Information
The following is an example of the CLI commands:
Binding MAC Address to VLANs
Binding MAC addresses to VLANs provides port to VLAN assignment based on MAC addresses. Once a
VLAN is assigned a MAC address, and the MAC address is learned on a port, the port joins the bound
VLAN. When the MAC address is aged out, the port leaves the VLAN. Only dynamic VLANs can be
bound to MAC addresses.
NOTE: The Bind MAC to VLAN feature (MAC to VLAN Assignment) is deprecated in versions that include the
Dynamic VLAN Assignment feature (DVA). DVA provides the same functionality as MAC to VLAN Assignment, but
does so in a standard way.
console(config)# interface port-channel 1
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 2
console(config-if)# exit
console(config)# interface port-channel 2
console(config-if)# switchport mode general
console(config-if)# switchport general allowed vlan add 2-3
tagged
console(config-if)# switchport general pvid 2
console(config-if)# switchport general acceptable-frame-type
tagged-only
console(config-if)# switchport general ingress-filtering
disable
console(config-if)# exit
console(config)# interface port-channel 3
console(config-if)# switchport mode trunk
console(config-if)# switchport trunk native vlan 3
console(config-if)# switchport trunk allowed vlan add 2