Example

Dell#configure terminal

 

Dell(conf)#ip vrf red

 

Dell(conf-vrf)#description "Red Network"

 

Dell(conf-vrf)#show config

 

!

 

ip vrf red 4

 

description "Red Network"

 

Dell(conf-vrf)#

 

Dell(conf-if-te-1/45)#int te 7/46

 

Dell(conf-if-te-1/46)#no shut

 

Dell(conf-if-te-1/46)#ip vrf forwarding red

 

Dell(conf-if-te-1/46)#ip add 100.1.1.1/24

 

Dell(conf-if-te-1/46)#

 

Dell(conf-if-te-1/46)#

 

Dell(conf-if-te-1/46)#

 

Dell(conf-if-te-1/46)#show config

 

!

 

interface TenGigabitEthernet 1/46

 

ip vrf forwarding red

 

ip address 100.1.1.1/24

 

no shutdown

 

Dell(conf-if-te-1/46)#

ip route-export

Enables route leaking between VRFs. Exports or shares IPv4 routes corresponding to one VRF with other non-default VRFs.

Syntax

Parameters

Defaults

Command Modes

ip route-export tag [route-map-name]

route-export

Enter the keyword to leak or share routes between VRFs.

tag

Enter a tag (export route target) to expose routes to other

 

VRFs. This tag acts as an identifier for exported routes. You

 

can use this identifier while importing these routes into

 

another non-default VRF.

route-map-

(Optional) Enter the name of the route-map to filter the

name

exported routes.

 

You can leak global routes to be made available to VRFs. As

 

the global RTM usually contains a large pool of routes, when

 

the destination VRF imports global routes, these routes will

 

be duplicated into the VRF's RTM. As a result, it is mandatory

 

to use route-maps to filter out leaked routes while sharing

 

global routes with VRFs.

N/A

 

VRF MODE

 

CONFIGURATION

 

1610

Virtual Routing and Forwarding (VRF)

Page 1610
Image 1610
Dell 9.7(0.0) manual Ip route-export, Example, Syntax Parameters Defaults Command Modes, Route-export, Route-map